AU06701 - Greater Bank - All jobs failing on login step for web connector
Incident Report for Basiq
Resolved
We have updated our Greater Bank connector and can confirm that it is now working as expected.

Thanks for your patience.

As always, please reach out to us if you are having any issues.
Posted Aug 14, 2023 - 16:31 AEST
Update
There has been a delay in Greater Bank's activation as a CDR data holder.

We do not know the reason or the new date, but as soon as the bank is active we will enable a CDR connector for them and will update this notice.

The ACCC's rectification schedule for data holders not yet active is here: https://www.cdr.gov.au/for-providers/rectification-schedules/rectification-schedule-data-holders-not-active
Posted Jul 17, 2023 - 09:28 AEST
Update
Unfortunately we have no option but to decommission the Greater Bank (AU06701) we connector: the bank is under no obligation to support screen scraping and has made a decision to block Basiq and other aggregators of financial data.

The bank is obliged to support customers' data sharing via the Consumer Data Right (CDR, or "open banking"); however they are not active yet. They are scheduled to be activated on 30 June 2023 - about 2 weeks' time.

Basiq is unable to support Greater Bank customers until the bank is activated as a CDR data holder. We recommend that consumers who have lost services and are inconvenienced as a result of this issue contact the bank's customer service directly.

Next actions:

( 1 ) Basiq will decommission the Greater Bank web connector

( 2 ) The bank is currently scheduled to become active as a CDR data holder by Friday 30 June

( 3 ) Once the bank is activated for CDR, Basiq will enable a CDR connector under the same institution ID, AU06701

( 4 ) Basiq customers enabled for CDR will be able to offer Greater Bank to their users again

We will keep this status notice open until the bank is available for CDR services.

CDR rectification schedule for data holders not active: https://www.cdr.gov.au/for-providers/rectification-schedules/rectification-schedule-data-holders-not-active (Greater Bank scheduled for 30 June 2023)
Posted Jun 19, 2023 - 12:00 AEST
Identified
Greater Bank have made a change to their internet banking portal which effectively detects and blocks the web connections used by Basiq and other aggregators to fetch data from the bank.

Banks have no obligation to allow web connections ("screen scraping") - but for most banks if they don't allow web connections there is a strong alternative. The Australian government has mandated that authorised deposit-taking institutions (ADIs) must participate in the new open banking framework known as the Consumer Data Right (CDR). Basiq customers can generally choose whether to fetch data from a given bank via web connections or CDR; over time it is likely that support for web connections may be phased out.

However, Greater Bank is not an active participant in the CDR framework. As the bank has started to block web connections, Greater Bank customers are left without an option to programmatically share their banking data with financial services of their choosing.

Greater Bank have a page advising customers on their current CDR status, here: https://www.greater.com.au/openbanking

We recommend that Greater Bank customers inconvenienced by this action reach out to the bank directly to understand their options and timeline for sharing data with accredited recipients.

We will update you via this ticket on a timeline to deactivating the Greater Bank web connector.
Posted May 29, 2023 - 12:28 AEST
Investigating
All Greater Bank jobs are currently failing on the login step.

Our team are investigating and we will update this notice with progress.
Posted May 26, 2023 - 10:53 AEST